android4.4.4设备报 java.lang.VerifyError错误。

项目是从Eclipse转到AndroidStudio上面的,转了之后运行发现5.0之上的系统可以用,4.4.4的手机会闪退。以下是异常栈:

DX)I$$V9ZZG9{R_8@~][{O3.png

弄了两天还是没有解决。
看起来是ViewPager的原因,网上说的可能是引用外部jar包问题,可是我还是没有解决办法。
这个是引用包:

D]EKZ0D@PV]99YXDRR$J@R2.png


求索- 7个月以前发出此问题
回答即可得2分,答案被采纳则奖励20分。

共1条回答

没遇到过此类问题,日志也没看出来个名堂